NAT (Network Address Translation) pada Router MikroTik

Belajar Mikrotik akhir-akhir ini menjadi salah satu kesibukan liburan semester saya. Disamping ingin memenuhi salah satu , ketertarikan saya untuk belajar Mikrotik juga didasari adanya permintaan teman untuk membantunya dalam proses skripsinya. Target awal nggak muluk-muluk deh, cukup sharing internet (NAT), selanjutnya ingin saya lanjutkan dengan load balancing, yang rencananya akan dibuat bahan skripsi Anyikku.

Pertama, kita perlu sedikit bahas dulu apa itu NAT? terus apa kegunaan dari NAT itu sendiri?

NAT kependekan dari (Network Address Translation), berfungsi untuk menerjemahkan atau mentranslasikan IP address Private ke IP address Public. Kenapa harus di translasikan ke IP Public?

Kita tahu, ada dua jenis IP address yaitu IP Private dan IP Public. IP yang di kenal oleh

internet atau yang bisa berinternet adalah IP Public. Kalo hanya ada satu IP Public tapi ada banyak PC yang ingin terkoneksi internet, bagaimana solusinya? Maka dari itu NAT dibutuhkan. Misal kita mempunyai konfigurasi jaringan sbb:

jaringanku

IP Private dan IP Public di atas hanya sebagai contoh, sesuaikan dengan IP Anda.

Keterangan Skema :

– PC Router Mikrotik dengan 2 ethernet card yaitu (publik) dan (local)

– Switch/Hub

– 3 PC sebagai Client masing-masing memiliki 1 ethernet card

Alokasi IP Address

PC Router Mikrotik

Ket:

eth0 = ethernet card 1 (Publik)

IP Address : 202.159.xx.xxx

Netmask : 255.255.255.252

Gateway : 202.159.xx.xxx

DNS 1/2 : 202.159.xx.x/202.159.xx.x

eth1 = ethernet card 2 (Local)

IP Address : 192.168.0.30/27

Gateway : 202.159.xx.xxx (gateway ISP)

PC Client

Client 1 – Client n, IP Address : 192.168.0.n …. n (1-30)

Contoh:

Client 1

IP Address : 192.168.0.1/27

Gateway : 192.168.0.30 (ke PC Router Mikrotik)

Client 2

IP Address : 192.168.0.2/27

Gateway : 192.168.0.30 (ke PC Router Mikrotik)

Client 3

IP Address : 192.168.0.3/27

Gateway : 192.168.0.30 (ke PC Router Mikrotik)

Ini Ada Sedikit Catatan :

Bahwa angka dibelakang IP Address, (/27) sama dengan nilai netmasknya. Untuk angka (/27) nilai netmasknya sama dengan (255.255.255.224). Sedangkan netmask yang Saya dapat dari ISP (255.255.255.252) nilainya sama dengan (/30).

Untuk SubNetmask blok IP Address kelas C, selengkapnya dapat dijelaskan sebagai berikut :

———————————-

Subnetmask kelas C

———————————-

255.255.255.0 = 24 -> 254 mesin

255.255.255.128 = 25 -> 128 mesin

255.255.255.192 = 26 -> 64 mesin

255.255.255.224 = 27 -> 32 mesin

255.255.255.240 = 28 -> 16 mesin

255.255.255.248 = 29 -> 8 mesin

255.255.255.252 = 30 -> 4 mesin

255.255.255.254 = 31 -> 2 mesin

255.255.255.255 = 32 -> 1 mesin

———————————-

Sebelum Anda melakukan installasi, jangan lupa Anda memilih Paket Mikrotik yang Anda butuhkan nantinya. Sesuaikan dengan kebutuhan Anda.

Proses installasi mikrotik tidak memakan waktu yang lama, sesuai dengan banyaknya paket yang akan anda install, normalnya tidak sampai 15 menit jika lebih berarti kemungkinan gagal, ulangi dari awal. Setelah proses installasi selesai maka kita akan diminta untuk merestart system, tekan enter untuk merestart system.

Setelah proses instalasi selesai, maka akan muncul menu login dalam modus

terminal, kondisi sistem saat ini dalam keadaan default.

Mikrotik login = admin

Password = (kosong, langsung tekan enter saja)

Setelah login, cek kondisi interface atau ethernet card.

Melihat kondisi interface pada Mikrotik Router

[admin@Mikrotik] > interface print

Flags: X – disabled, D – dynamic, R – running

# NAME TYPE RX-RATE TX-RATE MTU

0 R ether1 ether 0 0 1500

1 R ether2 ether 0 0 1500

[admin@Mikrotik]>

Jika interfacenya ada tanda X yang berarti (disabled) setelah nomor (0,1), maka periksa lagi etherned cardnya, seharusnya R yang berarti(running).

Setting IP Address, Gateway, Masqureade dan Name Server

Bentuk Perintah konfigurasi

Misalkan ether1 akan kita gunakan untuk koneksi ke Internet dengan IP 202.159.xx.xxx dan Local akan kita gunakan untuk network LAN kita dengan IP 192.168.0.30 (Lihat topologi dan konfigurasi di atas.

[admin@Mikrotik] > ip address add address=202.159.xx.xxx netmask=255.255.255.252 interface=ether1

[admin@Mikrotik] > ip address add address=192.168.0.30 netmask=255.255.255.224 interface=ether2

Melihat konfigurasi IP address yang sudah kita berikan

[admin@Mikrotik] >ip address print

Gateway

Bentuk Perintah Konfigurasi

Memberikan default Gateway, diasumsikan gateway untuk koneksi internet yang diperoleh dari ISP adalah 202.159.xx.xxx

[admin@Mikrotik] > /ip route add gateway=202.159.xx.xxx

Melihat Tabel routing pada Mikrotik Routers

[admin@Mikrotik] > ip route print

Tes Ping ke Gateway untuk memastikan konfigurasi sudah benar

[admin@Mikrotik] > ping 202.159.xx.xxx

202.159.xx.xxx 64 byte ping: ttl=64 time<1 ms

202.159.xx.xxx 64 byte ping: ttl=64 time<1 ms

2 packets transmitted, 2 packets received, 0% packet loss

round-trip min/avg/max = 0/0.0/0 ms

NAT (Network Address Translation)

Bentuk Perintah Konfigurasi

ip firewall nat add chain=srcnat action=masquerade out-inteface={Ethernet yang langsung terhubung ke Internet atau Public}

Setup Masquerading, Jika Mikrotik akan kita pergunakan sebagai gateway server maka agar client komputer pada network dapat terkoneksi ke internet perlu kita masquerading.

[admin@Mikrotik] > ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

Melihat konfigurasi Masquerading

[admin@Mikrotik] ip firewall nat print

Flags: X – disabled, I – invalid, D – dynamic

0 chain=srcnat out-interface=Public action=masquerade

Name server

Bentuk Perintah Konfigurasi

ip dns set primary-dns={dns pertama} secondary-dns={dns ke dua}

Setup DNS pada Mikrotik Routers, misalkan DNS dengan Ip Addressnya Primary = 202.159.xx.x, Secondary = 202.159.xx.x

Sebenarnya kita sudah cukup menggunakan Primary DNS nya saja. Tetapi jika Anda ingin menggunakan keduanya, tidak masalah.

[admin@Mikrotik] > ip dns set primary-dns=202.159.xx.x allow-remote-requests=yes

[admin@Mikrotik] > ip dns set secondary-dns=202.159.xx.x allow-remote-requests=yes

Melihat konfigurasi DNS

[admin@Mikrotik] > ip dns print

primary-dns: 202.159.xx.x

secondary-dns: 202.159.xx.x

allow-remote-requests: no

cache-size: 2048KiB

cache-max-ttl: 1w

cache-used: 16KiB

Tes untuk akses domain, misalnya dengan ping nama domain

[admin@Mikrotik] > ping google.com

Jika sudah berhasil reply berarti seting DNS sudah benar.

Setelah langkah ini bisa dilakukan pemeriksaan untuk koneksi dari jaringan local bisa kita mulai.

DHCP Server

DHCP merupakan singkatan dari Dynamic Host Configuration Protocol, yaitu suatu program yang memungkinkan pengaturan IP Address di dalam sebuah jaringan dilakukan terpusat di server, sehingga PC Client tidak perlu melakukan konfigurasi IP Addres secara manual.

untuk melakukan pengalamatan ip address untuk client.

Bentuk perintah konfigurasi

ip dhcp-server setup

dhcp server interface = { interface yang digunakan }

dhcp server space = { network yang akan di dhcp }

gateway for dhcp network = { ip gateway }

address to give out = { range ip address }

dns servers = { name server }

lease time = { waktu sewa yang diberikan }

Jika kita menginginkan client mendapatkan IP address secara otomatis maka perlu kita setup dhcp server pada Mikrotik. Berikut langkah-langkahnya :

Menambahkan IP address pool

[admin@Mikrotik] > /ip pool add name=dhcp-pool ranges=192.168.0.1-192.168.0.30

Menambahkan DHCP Network dan gatewaynya yang akan didistribusikan ke client

Pada contoh ini networknya adalah 192.168.0.0/27 dan gatewaynya 192.168.0.30

[admin@Mikrotik] > /ip dhcp-server network add address=192.168.0.0/27 gateway=192.168.0.30 dns-server=192.168.0.30

Tambahkan DHCP Server ( pada contoh ini dhcp diterapkan pada interface Local )

[admin@Mikrotik] > /ip dhcp-server add interface=ether2 address-pool=dhcp-pool

Melihat status DHCP server

[admin@Mikrotik] > ip dhcp-server print

Flags: X – disabled, I – invalid

# NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP

0 dhcp1 ether2

Oiya, perlu saya ingatkan, Jika yang muncul adalah Tanda X yang menyatakan bahwa DHCP server belum enable maka perlu kita enablekan terlebih dahulu. Tetapi jika keluar sesuai dengan contoh di atas berarti otomatis DHCP nya sudah aktif.

Enable dhcp server

[admin@Mikrotik] > /ip dhcp-server enable 0

Kemudian untuk memastikannya cek kembali dhcp-servernya dengan melihat status DHCP servernya, jika tanda X sudah tidak ada berarti sudah aktif.

Tes Dari client (apakah sudah mendapatkan IP, kalo sudah coba juga untuk browsing)

Dengan perintah :

C:>ipconfig

C:>ping http://www.rickymedia.wordpress.com

Selamat Mencoba, semoga membantu.

Explore posts in the same categories: Mikrotik

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s


%d blogger menyukai ini: